$re = '/\b\w*[yz](?<!(?:yz|zy))\b/';
$str = 'fez day fyyyz asdsd asdasdzy z y zy yz ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);