#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\s*<script.*>)((\s|.)*)(<\/script\s*?>)"
Local $sString = "<script type="text/template" data-category="text" data-img-src="section-01.jpg" data-section-name="1">" & @CRLF & _
"<div class="zpsection" data-element-type="section">" & @CRLF & _
" <div class="zpcontainer">" & @CRLF & _
" <div class="zprow" data-element-type="row" data-column-ratio="12,12">" & @CRLF & _
" <div class="zpcol-md-12 zpcol-sm-12" data-element-type="column">" & @CRLF & _
" <div class="zpelement zpelem-heading" data-element-type="heading">" & @CRLF & _
" <h2 class="zpheading zpheading-align-center" data-editor="true">The face of the moon was in shadow</h2>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="zpelement zpelem-text" data-element-type="text">" & @CRLF & _
" <div class="zptext zptext-align-center" data-editor="true">" & @CRLF & _
" <p>Almost before we knew it, we had left the ground. All their equipment and instruments are alive.Mist enveloped the ship three hours out from port. The spectacle before us was indeed sublime.A red flair silhouetted the jagged edge of a wing.</p>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="zpelement zpelem-button" data-element-type="button">" & @CRLF & _
" <div class="zpbutton-container zpbutton-align-center"> <a href="javascript:;" class="zpbutton-wrapper zpbutton zpbutton-type-primary zpbutton-size-md"> <span class="zpbutton-content">Get Started Now</span> </a> </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"</script>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")