#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)--([a-z\d]+)-A--[\s\S]+?--\1-Z--"
Local $sString = "--f15a0000-A--" & @CRLF & _
"[30/Aug/2018:14:06:33 +0200] W4fdyYHC0Xb8YDuIqk5YQgAAAD0 127.0.0.1 55454 127.0.0.1 80" & @CRLF & _
"--f15a0000-B--" & @CRLF & _
"GET /FormValidation/page1.php HTTP/1.1" & @CRLF & _
"Host: localhost" & @CRLF & _
"Connection: keep-alive" & @CRLF & _
"Upgrade-Insecure-Requests: 1" & @CRLF & _
"User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36" & @CRLF & _
"Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8" & @CRLF & _
"Referer: http://localhost/FormValidation/" & @CRLF & _
"Accept-Encoding: gzip, deflate, br" & @CRLF & _
"Accept-Language: en-US,en;q=0.9" & @CRLF & _
"tanuser: 00198343" & @CRLF & _
"" & @CRLF & _
"--f15a0000-F--" & @CRLF & _
"HTTP/1.1 200 OK" & @CRLF & _
"X-Powered-By: PHP/5.6.35" & @CRLF & _
"Content-Length: 851" & @CRLF & _
"Keep-Alive: timeout=5, max=99" & @CRLF & _
"Connection: Keep-Alive" & @CRLF & _
"Content-Type: text/html; charset=UTF-8" & @CRLF & _
"" & @CRLF & _
"--f15a0000-Z--" & @CRLF & _
"" & @CRLF & _
"--bb410000-A--" & @CRLF & _
"[30/Aug/2018:14:06:37 +0200] W4fdzYHC0Xb8YDuIqk5YQwAAAD0 127.0.0.1 55454 127.0.0.1 80" & @CRLF & _
"--bb410000-B--" & @CRLF & _
"POST /FormValidation/validation.php HTTP/1.1" & @CRLF & _
"Host: localhost" & @CRLF & _
"Connection: keep-alive" & @CRLF & _
"Content-Length: 33" & @CRLF & _
"Accept: */*" & @CRLF & _
"Origin: http://localhost" & @CRLF & _
"X-Requested-With: XMLHttpRequest" & @CRLF & _
"User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36" & @CRLF & _
"Content-Type: application/x-www-form-urlencoded; charset=UTF-8" & @CRLF & _
"Referer: http://localhost/FormValidation/page1.php" & @CRLF & _
"Accept-Encoding: gzip, deflate, br" & @CRLF & _
"Accept-Language: en-US,en;q=0.9" & @CRLF & _
"tanuser: 00198343" & @CRLF & _
"" & @CRLF & _
"--bb410000-C--" & @CRLF & _
"name1=test&email1=ssn%40gmail.com" & @CRLF & _
"--bb410000-F--" & @CRLF & _
"HTTP/1.1 200 OK" & @CRLF & _
"X-Powered-By: PHP/5.6.35" & @CRLF & _
"Content-Length: 17" & @CRLF & _
"Keep-Alive: timeout=5, max=98" & @CRLF & _
"Connection: Keep-Alive" & @CRLF & _
"Content-Type: text/html; charset=UTF-8" & @CRLF & _
"" & @CRLF & _
"--bb410000-Z--"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")