$re = '/(?:^| |[a-z][-_])\Kman/mi';
$str = 'man spider-man my man Jeeves
manpower iron_man yo-yo-man
woman human
-man';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);