$re = '/(\b\w+\b).*?(\1)$/m';
$str = 'test/fff/class/name-example/fff
test/fff/class/fff/name-example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);