#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)([^\n]*)\n+(.*)"
Local $sString = "Jean Trogger" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Curabitur ut scelerisque risus. Nunc cursus nisl a purus commodo, et commodo libero efficitur. Donec mattis metus turpis, et vestibulum lacus tempor eu.
Aliquam suscipit urna et nibh tristique, accumsan laoreet massa consectetur. Sed egestas ligula id erat iaculis, ac egestas arcu malesuada. Proin suscipit ipsum in accumsan interdum. Curabitur consequat sodales magna, vitae laoreet lorem vulputate eget. " & @CRLF & _
"Cras at eros in felis rhoncus facilisis nec laoreet felis. Curabitur condimentum metus a ipsum pulvinar hendrerit. Ut cursus hendrerit urna in volutpat. Morbi euismod felis venenatis facilisis hendrerit. Mauris fermentum id nibh commodo hendrerit. Quisque ornare sodales rhoncus. Nulla facilisi." & @CRLF & _
"Praesent ut pulvinar nibh. Fusce a felis quis augue hendrerit pellentesque. Aliquam blandit est sit amet consequat auctor. Phasellus blandit iaculis augue vitae lacinia. Donec lectus quam, hendrerit sed malesuada dapibus, aliquet vitae ex. Donec et erat congue, molestie lectus id, vestibulum lacus. Fusce auctor, diam quis ornare pharetra, enim nunc aliquet diam, eu scelerisque massa erat non libero. Proin gravida dignissim erat a eleifend. Duis porttitor massa a fringilla ullamcorper. Quisque aliquet iaculis mi vel venenatis. Ut eu suscipit massa, mollis finibus purus. Cras egestas leo lectus, eget cursus dui tempus quis." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")