#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https?://[-a-zA-Z0-9@:%._+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}[-a-zA-Z0-9()@:%_+.~#?&/=]*/?([-a-zA-Z0-9()@%_+~#?&/=]|\b))"
Local $sString = "Check https://example.com/path?param=value.with.dots for configuration." & @CRLF & _
"Check https://example.com/path?param=value.with.dots." & @CRLF & _
"Check https://example.com/path?param=value.with.dots. Or else." & @CRLF & _
"Visit https://example.com for more information." & @CRLF & _
"Check out https://github.com/user/repo, it's really good." & @CRLF & _
"The API endpoint is https://api.service.com/v1/data; use it carefully." & @CRLF & _
"Go to https://example.com: it has everything you need." & @CRLF & _
"See https://docs.example.com? It explains the process." & @CRLF & _
"Try https://example.com! It's amazing." & @CRLF & _
"The site (https://example.com) is down for maintenance." & @CRLF & _
"Links like https://example.com are common in emails." & @CRLF & _
"Visit https://example.com/path/file.pdf and download it." & @CRLF & _
"The URL https://example.com/api?key=123 returns JSON data." & @CRLF & _
"Check https://example.com, https://test.org, and https://demo.net." & @CRLF & _
"Go to https://example.com... wait, that's the wrong link." & @CRLF & _
"The website https://example.com-- actually, never mind." & @CRLF & _
"Visit https://example.com/path?q=value&r=2 for the search results." & @CRLF & _
"See https://example.com/file.html, then click the button." & @CRLF & _
"The documentation at https://docs.example.com; section 4.2 explains it." & @CRLF & _
"Try https://example.com:8080/api/v1/users for user data." & @CRLF & _
"Links: https://example.com, https://test.org; both are useful." & @CRLF & _
"Go to https://example.com/path/to/resource, download the file." & @CRLF & _
"The URL https://example.com/path#section contains the answer." & @CRLF & _
"Visit https://example.com/very/long/path/here for details." & @CRLF & _
"Check https://sub.domain.example.com for subdomain content." & @CRLF & _
"The site https://example.com/path.with.dots has interesting content." & @CRLF & _
"Go to https://example.com/path-with-dashes?, it's well organized." & @CRLF & _
"See https://example.com/path_with_underscores for more info." & @CRLF & _
"The endpoint https://api.example.com/v2/data?format=json returns data." & @CRLF & _
"Visit https://example.com/file.tar.gz to download the archive." & @CRLF & _
"The URL https://192.168.1.1:8080 is for local testing." & @CRLF & _
"Go to https://example.com/path/ (note the trailing slash)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")