# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([$^]{2,}|\d +\d|(?<!\w )[$^]\d)"
test_str = ("\"#5 #5 #5\"\n"
"\"5 ^5.321 $#2.6\"\n"
"\"5^#4.5\"\n"
"\"#5#5#5\"\n"
"\"56.2\"\n"
"\"5 6\" (reason: separated by a space)\n"
"\"5^^5\" (reason: two special characters next to each other)\n"
"\"5^^^##5\" (reason: way too many special characters next to each other)\n"
"\"^5\" (reason: no number before \"^\")\n"
"\"^5&\" (reason: no number before \"^\" AND no number after \"&\")")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.