$re = '/^(?=.*?[A-Za-z0-9#!@$%^&*()+=])\S{8,20}$/m';
$str = 'Password@345
Password @ 345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);