const regex = new RegExp('code=(.*)\\" target', 'g')
const str = `?code=teststestestesttestetest\\" target=\\"_blank\\"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);