$re = '/((?![b-z])[a-z])(?:(?!\1).)*?3/m';
$str = 'abc1 abc2 abc3 abc4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);