$re = '/^[a-z0-9_-]{3,15}$/m';
$str = 'john_doe
jo-hn_doe
john12_as
Jo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);