re = /^outgoingaff\.txt|outgoingopsc2days\.txt|outgoingopsc6days\.txt$/m
str = 'outgoing.txt
outgoingaff.txt
outgoingopsc2days.txt
outgoingopsc6days.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end