import re
regex = re.compile(r"^\+[\d\*]{11,13}$", flags=re.MULTILINE)
test_str = ("Cas passants :\n"
"+3362788****\n"
"+337**0140**\n"
"+336********\n"
"+491**********\n"
"+3362788******\n"
"+491**27880140\n"
"+49106**88**40\n"
"+32*********\n\n"
"Cas non passants :\n"
"+3362788*******\n"
"+49 1** *** ** **\n"
"062788****\n"
"+33627*****\n"
"+33627**014\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")