re = /(\S+)=["']?((?:.(?!["']?\s+(?:\S+)=|[>"']))+.)["']?/
str = 'url="https://www.youtube.com/watch?v=123456"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end