# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?: # 采用非捕获括号进行分组(非必要不使用捕获型括号)
```[\s\S]*?``` # 采用非贪婪匹配(必须),匹配0到n次空白或非空白字符(任意字符)
) # 结束第一个分支
| # 或符号
(?: # 同上,采用非捕获型括号
~~~[\s\S]*?~~~ # 同上,非贪婪匹配来匹配0到n次空白或非空白字符
) # 结束第二个分支
"""
test_str = ("// 1. 匹配四个空格导出的代码块\n\n"
" functino(asfd)\n"
" safdsadf\n"
" safsadf\n"
" safdsdaf\n\n\n\n"
"// 2. 匹配三个反引号所引出的代码块\n"
"```\n"
" func function(){\n"
" }\n"
"```\n\n"
"这里是一些文本\n"
"……\n"
"………………\n\n"
"``` python\n"
" print(\"hello\")\n"
"```\n\n"
"// 3.如果四个空格之前的一行不是回车独占一行,则不会导出代码块(符合Markdown约定)\n"
" functino(asfd)\n"
" safdsadf\n"
" safsadf\n"
" safdsdaf\n"
"safd\n\n"
"// 4. 匹配三个波浪号导出的代码块\n\n"
"~~~\n"
" fmt.println(123)\n"
"~~~\n\n"
"// 5. 匹配前后四个及以上反引号导出的代码块\n"
"````\n"
"aaa\n"
"```\n"
"````\n\n"
"这里是一些文本……\n\n"
"`````\n"
" print(\"this is a code block\")\n"
"`````\n\n"
"// 6. 匹配前后四个及以上波浪号导出的代码块\n"
"~~~~\n"
"aaa\n"
"~~~\n"
"~~~~\n\n"
"这里是一些文本……\n\n"
"~~~~~~\n"
" print(\"this is a code block\")\n"
"~~~~~~\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.