$re = '/^\/.well-known\/acme-challenge\/(.*)/m';
$str = '/.well-known/acme-challenge/
/.well-known/acme-challenge/232398239283
/notletsencryptpage
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);