$re = '/\p{L}+|\p{M}+/um';
$str = 'Hakan Çalhanoğlu
Schüller Küchen
mør
Mark Cuban
M2 1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);