re = /((?:(?:H[eogf]?|L[iau]|B[eari]?|C[arouseld]?|N[eiapdb]?|O[sg]?|F[rle]?|M[gon]|A[lrsgutc]|S[icernmb]?|P[uabotmrd]?|Kr?|T[icebmalh]|V|Z[nr]|G[ade]|R[buhena]|Yb?|I[nr]?|Xe|E[ur]|Dy|W|U)+(?:(?:<su[bp]>(?:[2-9][0-9]*)<\/su[bp]>)|[2-9][0-9]*)*){2,})/m
str = '\\nNH<sub>2</sub>CONH<sub>21</sub>, F.W.
\\nsNH<sub>2</sub>CONH, F.W. 60.06<br />\\nCAS No. 57-13-6</p>\\n<p>Shipping: Not regulated for
/>\\nFeO<sub>2</sub>dsa
fooasdfNH<sub>2</sub>CONH<sub>2</sub>NH<sub>2</sub>CONH<sub>2</sub>NH<sub>2</sub>CONH<sub>2</sub>NH<sub>2</sub>CONH<sub>2</sub>He
NH2CONH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end