$re = '/(?<=ab|a(?!b)|b)/m';
$str = 'a ab b a ab a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);