use strict;
my $str = 'http://foxcat:hunter2@ftp.example.com/a/funny/path/to/@v3.0.0.tar.gz?t=1394939395#why-is-there-a-fragment-here
https://github.com∕kubernetes∕kubernetes∕archive∕refs∕tags∕@v1271.zip';
my $regex = qr/^(?<scheme>[a-z]+:\/\/)(?:(?<username>[^\/:@]+)(?::(?<password>[^\/:@]+))?@)?(?<host>[^\/]+)(?:(?<path>\/[^?#]+)(?:(?<query>[^#]+)?)?(?:#(?<fragment>.*))?)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}