$re = '/(?<![一-龯])[一-龯](?![一-龯])/m';
$str = 'Capturing standalone kanji like 偶 and avoiding group like 健康、保健.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);