$re = '/\[(?![^][]*\btable\b)[^][]*]/m';
$str = '[1 table 2] [1 notable 2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);