import re
regex = re.compile(r"(\S.*):\n\s*(\+?\d[\d.]*%)\s+in\s+(.*)", flags=re.MULTILINE)
test_str = ("Consumer Price Index:\n"
" +0.2% in Sep 2020\n\n"
" Unemployment Rate:\n"
" +7.9% in Sep 2020\n\n"
" Producer Price Index:\n"
" +0.4% in Sep 2020\n\n"
" Employment Cost Index:\n"
" +0.5% in 2nd Qtr of 2020\n\n"
" Productivity:\n"
" +10.1% in 2nd Qtr of 2020\n\n"
" Import Price Index:\n"
" +0.3% in Sep 2020\n\n"
" Export Price Index:\n"
" +0.6% in Sep 2020")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")