$re = '/([0-9]{6})+(-)+([A-Z]{1})/mus';
$str = '671233-H';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);