re = /(.+?)(\{startMarker\}|\{endMarker\}|$)/m
str = 'This is {startMarker} the string {endMarker} for {startMarker} example. {endMarker}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end