re = /^(?!.*V2|.*WebResource).*(?=\.Time$)/m
str = 'BumpCardV2Resource.getInstance.Time
BumpCardWebResource.getInstance.Time
BumpCardResource.getInstance.Time'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end