#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-zéúíóáÉÚÍÓÁèùìòàçÇÈÙÌÒÀõãñÕÃÑêûîôâÊÛÎÔÂëÿüïöäËYÜÏÖÄ]+([\-'][A-Za-zéúíóáÉÚÍÓÁèùìòàçÇÈÙÌÒÀõãñÕÃÑêûîôâÊÛÎÔÂëÿüïöäËYÜÏÖÄ]+)?)( [A-Za-zéúíóáÉÚÍÓÁèùìòàçÇÈÙÌÒÀõãñÕÃÑêûîôâÊÛÎÔÂëÿüïöäËYÜÏÖÄ]+([\-'][A-Za-zéúíóáÉÚÍÓÁèùìòàçÇÈÙÌÒÀõãñÕÃÑêûîôâÊÛÎÔÂëÿüïöäËYÜÏÖÄ]+)?)+$"
Local $sString = "Fulano de Tal" & @CRLF & _
"José da Silva Ábcde" & @CRLF & _
"" & @CRLF & _
"---------- nomes com hífen ou apóstrofo" & @CRLF & _
"Shaun Cameron Wright-Phillips" & @CRLF & _
"Ciclano D'aquino de Souza" & @CRLF & _
"" & @CRLF & _
"--------------------------------" & @CRLF & _
"--- nomes inválidos" & @CRLF & _
"" & @CRLF & _
"-- não tem sobrenome" & @CRLF & _
"Ciclano" & @CRLF & _
"-- números" & @CRLF & _
"Fulano1 da Silva"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")