using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<!\[CDATA\[(?<cdata>.*?)\]\]>|(?<xml><\?.*?\?>)|<!--(?<comment>.*?)-->|<\s*(?<tag>[A-z][A-z0-9-_.:]*)(?:\s+(?:[A-z][A-z0-9-_.:]*)\s*(?:=\s*(?<quote>[""'])((?:\\\k<quote>|(?:(?!\k<quote>)).)*)(\k<quote>)\s*)?)*\s*(?:/\s*>|>(?<innerHTML>.*)?<\s*/\s*\k<tag>\s*>)|(?<text>[^<]*))";
string input = @"<?xml version='1.0' encoding='shift_jis'?>
<!-- foo -->
<foo>bar</foo>
Baz
<foo asdf=""foo"" />
<CharacterInfo defaultUid=''>
<Character
name='??????'
uid='511111'
weapon='??'
HR='7' GR='0' lastLogin='1645561498'
sex='M' />
<Character name ='Potatoe/>sss' uid= '511111' weapon = '??' HR='7' GR=""0"" lastLogin='1645561498' sex='M' />
</CharacterInfo>
Plain text
<hr/>
Multi
line
text
<br />
<!--
This is a comment!
<foo />
-->
<foo
bar/>
<baz asdf=""2""></baz>
<asd foo=""asd\""q'we"" / >
<b>Hello, <i>World</i>!</b>
<Character
name='??????'
uid='511111'
weapon='??'
HR='7' GR='0' lastLogin='1645561498'
sex='M' />
<Character name ='Potatoe/>sss' uid= '511111' weapon = '??' HR='7' GR=""0"" lastLogin='1645561498' sex='M' />
<![CDATA[]]>
<![CDATA[Foobar<>]]>
<![CDATA[
asdasdasd
adsd
sd
sd
]]>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}