#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\(((?:RR|RI|PC|PR|PA)R\d{3}){0,1}\) \[([1-2]\d{7}@\d{6})\]\.(( <<.*>>)|( (?!<<).+)){0,1}$"
Local $sString = "None (PRR001) [11111111@111111]. <<freetext>>" & @CRLF & _
"None (RIR001) [11111111@111111]. <<freetext>>" & @CRLF & _
"None (RRR001) [11111111@111111]. <<freetext>>" & @CRLF & _
"Prescribing Error (PCR001) [11111111@111111]. <<freetext>>" & @CRLF & _
"None (PAR001) [11111111@111111]. <<freetext>>" & @CRLF & _
"" & @CRLF & _
"None (RIR001) [11111111@111111]. a" & @CRLF & _
"None (RIR001) [11111111@111111]. <a>>" & @CRLF & _
"" & @CRLF & _
"--GOOD Leading and trailing spaces are ignored" & @CRLF & _
"None (PRR001) [11111111@111111]. << freetext >>" & @CRLF & _
"" & @CRLF & _
"--GOOD One element missing" & @CRLF & _
"(PRR001) [11111111@111111]. <<freetext>>" & @CRLF & _
"(PRR001) [11111111@111111]. <<freetext>>" & @CRLF & _
"None () [11111111@111111]. <<freetext>>" & @CRLF & _
"None (PRR001) [11111111@111111]. <<>>" & @CRLF & _
"None (PRR001) [11111111@111111]." & @CRLF & _
"" & @CRLF & _
"--GOOD Freetext embedded <<>>. Leading and trailing spaces" & @CRLF & _
"None (PRR001) [11111111@111111]. <<C<<B>>A>>" & @CRLF & _
"" & @CRLF & _
"--GOOD Old Reason format with correct event type." & @CRLF & _
"Prescription Reprint <<>>" & @CRLF & _
"Prescription Reprint <<chewed up>>" & @CRLF & _
"" & @CRLF & _
"--GOOD Old Reason format with with freetext embedded <<>>" & @CRLF & _
"Prescription Reprint <<C<<B>>A>>" & @CRLF & _
"" & @CRLF & _
"--GOOD Longer than 400" & @CRLF & _
"None (PRR001) [11111111@111111]. <<Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nullam ultrices orci non leo volutpat, at sagittis dolor cursus. Duis ullamcorper laoreet scelerisque. Donec eu nulla nec erat eleifend consectetur. Donec tincidunt, risus id imperdiet consectetur, eros mauris pharetra purus, in rhoncus diam massa ac elit. Suspendisse eleifend erat vitae cras amet.>>" & @CRLF & _
"" & @CRLF & _
"--GOOD <400 freetext > 350" & @CRLF & _
"None (PRR001) [11111111@111111]. <<Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed condimentum, erat nec rhoncus porta, urna sem laoreet elit, sed tempus augue erat nec odio. Morbi facilisis porttitor dolor sodales blandit. Phasellus lobortis ligula sit amet elit sagittis, eu ultrices mi aliquet. Curabitur a odio mauris. Nam quis ullamcorper elit. In dignissim ac nullam.>>" & @CRLF & _
"" & @CRLF & _
"--GOOD <CR><LF><TAB>" & @CRLF & _
"None (PRR001) [11111111@111111]. <<EA\r\nB\t\tC>>" & @CRLF & _
"" & @CRLF & _
"--BAD Prove only certain codes looked at" & @CRLF & _
"None (PRR001) [11111111@111111]. <<freetext>>" & @CRLF & _
"" & @CRLF & _
"--BAD One element missing" & @CRLF & _
"None (PRR001) []. <<freetext>>" & @CRLF & _
"" & @CRLF & _
"--BAD Code not RRRnnn,RIRnnn,PCRnnn,PRRnnn or PARnnn" & @CRLF & _
"None (PIR001) [11111111@111111]." & @CRLF & _
"None (RCR001) [11111111@111111]." & @CRLF & _
"None (RAR001) [11111111@111111]." & @CRLF & _
"None (RIR00A) [11111111@111111]." & @CRLF & _
"None (RIRA01) [11111111@111111]." & @CRLF & _
"None (RIR0A1) [11111111@111111]." & @CRLF & _
"None (RIR 01) [11111111@111111]." & @CRLF & _
"None (RIR0 1) [11111111@111111]." & @CRLF & _
"None (RIR00 ) [11111111@111111]." & @CRLF & _
"None (RIR001 ) [11111111@111111]." & @CRLF & _
"None (RIR0001) [11111111@111111]." & @CRLF & _
"None ( RIR001) [11111111@111111]." & @CRLF & _
"None (RIR001 [11111111@111111]." & @CRLF & _
"None RIR001) [11111111@111111]." & @CRLF & _
"None (RIR01) [11111111@111111]." & @CRLF & _
"None (EVE001) [11111111@111111]." & @CRLF & _
"" & @CRLF & _
"--BAD Date time not \[([1-2]\d{7}@\d{6})\]" & @CRLF & _
"None (RIR001) 11111111@111111]." & @CRLF & _
"None (RIR001) [11111111@111111." & @CRLF & _
"None (RIR001) [1111111@111111]." & @CRLF & _
"None (RIR001) [111111111@111111]." & @CRLF & _
"None (RIR001) [11111111@11111]." & @CRLF & _
"None (RIR001) [11111111@1111111]." & @CRLF & _
"None (RIR001) [91111111@111111]." & @CRLF & _
"None (RIR001) [11111111@11A111]." & @CRLF & _
"None (RIR001) [111A1111@111111]." & @CRLF & _
"None (RIR001) [11111111x111111]." & @CRLF & _
"None (RIR001) [11111111111111]." & @CRLF & _
"None (RIR001) []." & @CRLF & _
"None (RIR001)." & @CRLF & _
"" & @CRLF & _
"--BAD Reason text, code, date time with no ." & @CRLF & _
"None (RIR001) [11111111@111111]" & @CRLF & _
"" & @CRLF & _
"--BAD Invalid freetext ( <<.*>>){0,1}" & @CRLF & _
"None (RIR001) [11111111@111111].a" & @CRLF & _
"None (RIR001) [11111111@111111]. " & @CRLF & _
"None (RIR001) [11111111@111111]. <<a>" & @CRLF & _
"None (RIR001) [11111111@111111]. <<>> a" & @CRLF & _
"None (PRR001) [11111111@111111]. <<C<<B>>A" & @CRLF & _
"None (PRR001) [11111111@111111]. <<venalink" & @CRLF & _
"" & @CRLF & _
"--BAD Old Reason format with wrong event type." & @CRLF & _
"Prescription Reprint" & @CRLF & _
"Prescription Reprint" & @CRLF & _
"Prescription Reprint" & @CRLF & _
"Prescription Reprint" & @CRLF & _
"Prescription Reprint" & @CRLF & _
"Prescription Reprint <<>>" & @CRLF & _
"Prescription Reprint <<>>" & @CRLF & _
"Prescription Reprint <<>>" & @CRLF & _
"Prescription Reprint <<>>" & @CRLF & _
"Prescription Reprint <<chewed up>>" & @CRLF & _
"Prescription Reprint <<chewed up>>" & @CRLF & _
"Prescription Reprint <<chewed up>>" & @CRLF & _
"Prescription Reprint <<chewed up>>" & @CRLF & _
"Prescription Reprint <<C<<B>>A" & @CRLF & _
"Prescription Reprint <<C<<B>>A" & @CRLF & _
"Prescription Reprint <<C<<B>>A" & @CRLF & _
"Prescription Reprint <<C<<B>>A" & @CRLF & _
"" & @CRLF & _
"--BAD Old Reason format with with freetext embedded <<>> and no Trailing >>" & @CRLF & _
"Prescription Reprint <<C<<B>>A" & @CRLF & _
"" & @CRLF & _
"--OTHER BAD EXAMPLES" & @CRLF & _
"" & @CRLF & _
"Existing letter file 'P:\WORDPROC\CLINCORR\0046O000.CLI' deleted when adding letter" & @CRLF & _
"" & @CRLF & _
"Vision 2.00 Install successful on Computername: RECEPTION for filesystem: Live System - Live" & @CRLF & _
"" & @CRLF & _
"Typed in name: MD" & @CRLF & _
"" & @CRLF & _
"Mode=LEGACY;Token Id=AQIC5wM2LY4SfcyXAQB0EBD9MWbdEKQjnCGKw8iNj6Gu3FU=;RoleProfile=339601626031;Role=R1740" & @CRLF & _
"" & @CRLF & _
"Prescription Reprint <<chewed up>>" & @CRLF & _
"" & @CRLF & _
"Mode=CACHED PROFILE;Token Id=;RoleProfile=;Role=,User=SYS" & @CRLF & _
"" & @CRLF & _
"14.9" & @CRLF & _
"" & @CRLF & _
"Vision 22.00.0004 Install successful on Computername: CON06 for filesystem: Live System - Live" & @CRLF & _
"" & @CRLF & _
"ÃÂ?Â?Â?Â?Â?Â<ÿUÂ<ìƒì(SVWÂ?zøÂ?Â"[K" & @CRLF & _
"" & @CRLF & _
"Existing letter file 'P:\WORDPROC\CLINCORR\00311000.CLI' deleted when adding letter" & @CRLF & _
"" & @CRLF & _
"Quarter 1 2000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")