re = /((http(s)?):\/\/)(((25[0-5]|(2[0-4]|1[0-9]|[1-9]|)[0-9])(\.(?!$)|$)){4}$|(.*\.local)|(.*local\.)|(.*localhost)|(.*\.internal)|(.*csb.)|(.*codesandbox)|(.*lvh\.me)|(.*.ngrok.)|(.*nip\.io)|(.*.test)).*/m
str = 'http://localhost:9999/
https://localhost:0000
http://stackoverflow.com/challenge
https://arseniyaskingquestion.ru/SO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end