package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(abc_.*)?("")?`)
var str = `""
adsasd
abc_mnzxkasjdmasdo
abci`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}