$re = '/(?:#(?:(?:[0-1]+(?::-?\d+)?b)|(?:[0-7]+(?::-?\d+)?o)|(?:[0-9A-F]+(?::-?\d+)?h)|(?:[0-9]+(?::-?\d+)?d?)|))|(?:(?<![a-z])-?\d+(?:\.\d+)?º?)/m';
$str = '#0123456789ABCDEF:64h #0123456789d #01234567o #01b
7.75º
LOCAL variable1 := 123456789;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);