$re = '/(?<!\S)@(\w{4,15})\b(?![^@\n]*@)/m';
$str = '@username!&?()*^
@username@username
@username!?>@
not@username
!@username
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);