#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<\/a>)([^<]+)?(<\/p>)"
Local $sString = "<p class="calibre1"><a id="p1"></a>Chapter 370: Slamming straight on</p>" & @CRLF & _
"<p class="softbreak"> </p>" & @CRLF & _
"<p class="calibre1">Hearing Yan Zhaoge’s suggestion, the Jade Sea City martial practitioners here were all stunned.</p>" & @CRLF & _
"<p class="calibre1"><a id="p7"></a>Chapter 372: Yan Zhaoge’s plan</p>" & @CRLF & _
"<p class="softbreak"> </p>" & @CRLF & _
"<p class="calibre1">Yan Zhaoge and Ah Hu sat on Pan-Pan’s back, black water swirling about Pan-Pan’s entire body, keeping away the seawater as he shot forward at lightning speed.</p>"
Local $sSubst = "\1<h2>\2</h2>\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)