$re = '/^\[(?<number>[\d]+(?>\.[\d]{2})?)\|(?<codes>(?>[A-Z]{2},?)+)(?>\s\"(?<comment>.+)\")?\]$/m';
$str = '[15.00|GR,LQ,MD "Uber"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);