$re = '/(follow me|check out my|follow my).{0,20}(work|page|instagram|ig|portfolio|account)|(for hire|hire me|available for|taking clients|open for|freelance available)|(dm me|pm me|hit me up|contact me|message me).{0,20}(for|about|if|to)|(www\.|https?:\/\/|\b\w+\.com|\b\w+\.co\.uk|\b\w+\.net|\b\w+\.org)|(@[a-zA-Z0-9_]+)|(survey|poll|questionnaire|research study|thesis)|(join my|my discord|telegram|whatsapp).{0,20}(group|server|channel|chat)|(fiverr|upwork).{0,20}(profile|page)|(subscribe|like and subscribe)/m';
$str = 'like and subscribe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);