$re = '/^#?[a-zA-Z0-9][^\n#<>@.\/()]+$/m';
$str = '##msidfipds
fdsfsdfd#1m
vcvxcvxcvxc
#fdfdsfsdfs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);