re = /^\S+\s(?<microService>\S+).*.\[\[(?<url>[^\]]+)/m
str = '2022-09-07T01:42:06.321624+00:00 micro.service 2867ce23-bdfd-48eb-ba5a-40e1e8a93987[[APP/PROC/WEB/0]] 159.203.190.66, 100.64.144.3 - - - [07/Sep/2022:01:42:06 +0000] "GET url HTTP/1.1" 404 125'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end