import re
regex = re.compile((r"^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<secondaryId>(\d{1,2}|x)p)(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$\n"), flags=re.MULTILINE)
test_str = ("Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_0p_r3.indd\n"
"Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_1p_r3.indd\n"
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_2p_r3.indd\n"
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_123p_r3.indd\n"
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_tx_xp_r3.indd\n\n"
"Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")