$re = '/<(\w+).*>(.*?)<\/\1>/m';
$str = '<html>frejkngrk kej grek erg</html>
<body>Lorem ipsum</body> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);