import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<Root>file\\:\\/\\/\\/(?:[A-Za-z]+):(?:\\/|\\\\)|https\\:\\/\\/)(?P<Relative>(?:(?:[^<>:\"\\/\\\\|?*\\n])+(?:\\/|\\\\))+)(?P<File>(?:[^<>:\"\\/\\\\|?*\\n]+)(?:\\.(?:pdf)))$";
final String string = "file:///D:/Documents/My%20Documents/T09_27jun-17jul_V_Fro.pdf\n\n"
+ "file:///z:/Documents/My%20Documents/pdfs/eggs,%20milk,%20fruit.pdf\n\n"
+ "file:///zz:/Documents/My%20Documents/example.folder/icebreaker.pdf\n\n"
+ "file:///abv:/program%20shmogram%20(x86)/CoolTheVideoGameTheMovie/lewd.mods/uwuDialogueforFemales.pdf\n\n"
+ "file:///h:/Documents/My%20Documents/example.folder/New%20folder/ExamplE%20folder%203/very_cool_kanye.pdf\n\n"
+ "https://www.samsclub.com/savings/20230626/T09_27jun-17jul_V_Fro.pdf\n\n"
+ "https://whatkindofprefixisthis.RobertTheWebsite.io/AboutUs/Who-Da-frick_IS_Robert-anyways.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}