import re
regex = re.compile(r"(art\.?|artigos?) ([0-9.]{1,7}).{1,20}?(§ ?\d{1,3})?.{1,20}?(CPC|CPP|C[oOÓó]digo de Processo Penal|C[oOÓó]digo de Processo Civil|C[oOÓó]digo Penal|CP(?!C)|CPC|Lei de Execuções Penais|Constituição da República|[0-9]{1,3}.[0-9]{3}(\/[0-9]{2,4})?)", flags=re.MULTILINE)
test_str = ("sta os elementos dos autos, em especial o teor das declarações colhidas em sede policial (fls. 03 e 07/08), acolho o posicionamento das partes, reconheço a atipicidade da conduta imputada à demandada e, via de consequência, julgo improcedente a pretensão punitiva estatal, ABSOLVENDO SUMARIAMENTE, como absolvida tenho, a ré Iana da Silva Nogueira da imputação de cometimento do crime previsto no art. 140, §3º, do Código Penal, fundamentando a absolvição no art. 397, III, do Código de Processo Penal.\n"
"Sem custas, face ao teor da presente decisão. Decorrido o prazo recursal, dê-se baixa e arquive-se. Providencie a Serventia as diligências, anotações e comunicações necessárias. Certifique-se.\n"
"Publicada em audiência, dou por intimadas as partes presentes. Registre-se.\n"
"Nada mais havendo, foi a presente encerrada, que lida e achada conforme, vai devidamente assinada, às 20:00 horas. Eu, AJLFF, Secretário, mat. 01/30003, digitei e subscrevi. Nada mais. Esta conforme. Dou fé.\n\n"
"1- Quanto aos arts.21 da LCP e art.147 do C.P. trata-se de procedimento versando sobre infração de menor potencial ofensivo. As vítimas deixaram de praticarrem ato necessário à continuação do feito conforme fls.06, demonstrando evidente desinteresse em seu prosseguimento e, assim, renunciando tacitamente ao direito de representação. Assim, JULGO EXTINTA A PUNIBILIDADE do autor da infração, nos termos do disposto no inciso V do artigo 107 do Código Penal. Sem Custas, na forma do art. 54 da Lei 9.099/95. Dê-se baixa e arquive-se.\n\n"
"Em 22 de agosto de 2019, à hora marcada, na sala de audiências do Juízo da 2ª Vara Criminal da Comarca de Itaboraí, realizou-se a audiência, referente ao processo supra, sob a presidência MMª. Juíza de Direito Dra. JULIANA CARDOSO MONTEIRO DE BARROS. Presente a I. Representante do Ministério Público. Feito o pregão de estilo, compareceram os autores do fato, informando que a situação se apaziguou não tendo mais interesse me prosseguir com o feito. Pelo Ministério Público foi dito que desiste da oitiva das demais testemunhas e requer absolvição dos acusados por falta de provas, na forma do artigo 386, VII do CPP. A Defensoria Pública corrobora as alegações finais do MP. Pela MMª. Juíza foi proferida a seguinte SENTENÇA: Trata-se de Ação Penal em que é acusado BRUNO DO AMOR DIVINO DE JESUS e MAIZA DA SILVA GOMES DE JESUS, tendo-lhes sido imputada a prática do delito tipificado no art. 21 da DL 3.688/41. Ao final da instrução criminal, não restaram comprovados os fatos narrados na denúncia. A autoria do delito em tela não é segura. Sobressai a dúvida especialmente se desincumbiu de seu ônus probatório. Compulsando os autos, conclui-se que a pretensão inicial acusatória não merece prosperar pelos motivos elencados. Ante a ausência da prova produzida pela acusação e a manifestação do Ministério Público pela absolvição, deve-se aplicar o brocardo in dubio pro reo, a fim de absolvê-lo da presente imputação. Pelo exposto, JULGO IMPROCEDENTE o pedido contido na denúncia, para absolver os acusados BRUNO DO AMOR DIVINO DE JESUS e MAIZA DA SILVA GOMES DE JESUS, com fulcro no art. 386, VII do Código de Processo Penal. As partes renunciam ao prazo recursal. Publicada em audiência. Intimados os presentes. Transitada em julgado neste ato. Dê-se baixa e arquivem-se. Sem custas. Publicada em audiência. Intimados os presentes.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")