package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)abc*`)
var str = `abasdlkqeqwnvzmawdnoijqpriweqabcccqwejlab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}