$re = '/[^ \u00C0-\u017F]/';
$str = 'abc def è à ç çaçfçç';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);