$re = '/Born.*\n.*\n((.*\n)*)Died/m';
$str = 'Born Chandrasekhara Venkata Raman
7 November 1888
Tiruchirapalli,
Madras Presidency,
British India
(now Tamil Nadu, India)
Died 21 November 1970 (aged 82)
Bangalore, Mysore, India
Alma mater University of Madras (B.A., M.A.)
Known for Raman effect';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);