const regex = /(\+?\d+)?\s?(\(\d{2}\))?\d{4,5}-\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+?\\d+)?\\s?(\\(\\d{2}\\))?\\d{4,5}-\\d{4}', 'gm')
const str = `- (11)98756-1212
- 98765-4321
-+55 (11)94362-3708
- 97333-3723
- 98733-4344
- (11)97283-3849
- 55 92829-2304
1196377-3243`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}