package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s+|(?<a>\w\).*)|(?<q>.*)`)
var str = `pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta
pergunta quanto é pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta
a) resposta a
b) resposta b
c) resposta c
d) resposta d
e) resposta e
_) respsota _`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}