import re
regex = re.compile(r"\s+(*SKIP)(*FAIL)|(?<a>\w\).*)|(?<q>.*)")
test_str = ("pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta\n\n"
"pergunta quanto é pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta\n\n"
" a) resposta a\n\n"
" b) resposta b \n\n"
" c) resposta c\n\n"
" d) resposta d\n\n"
" e) resposta e\n\n"
" _) respsota _")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")