$re = '/([-+][\d\.]*)/m';
$str = 'SO4-2
Na+
B(OH)4-
(Na)+
Na(+)
Mg++
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);